City HDU - 4496 (并查集+小转换)

Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input

First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4

Sample Output

1 
1 
1 
2 
2 
2 
2 
3 
4 
5

        
  

Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. 
The first 3 lines of output are 1s  because  after  deleting  the  first  3  edges  of  the  graph,  all  vertexes  still  connected together. 
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. 
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N. 

题意:

给你一个图 , n个点,m条边。输出删除第i条边的时候,该图的连通块的个数。

思路:正向删边不好解决,那么可以反向增边,将此时的连通块个数个数存下来, 输出的时候反向输出即可。

代码:

#include <stdio.h>
#include <iostream>
using namespace std;
const int maxn = 100000 + 8;
int father[maxn] ,total;
struct node 
{
	int a ;
	int b;
}s[maxn];
void init()
{
	for(int i = 0 ; i < maxn ; i++)
	{
		father[i] = i;
	}
}
int getf(int x)
{
	return x == father[x] ? x : father[x] = getf(father[x]);
}
bool merge(int x , int y)
{
	int fx = getf(x);
	int fy = getf(y);
	if(fx != fy)
	{
		father[fx] = fy;
		return true;
	}
	else
	{
		return false;
	}

}
int main()
{
	int n , m ;
	int ans[maxn] , t;
	while(~scanf("%d %d" , &n , &m))
	{
		t = 0;
		total = n;
		ans[t] = total;
		init();
		for(int i = 0 ; i < m ; i++)
		{
			scanf("%d %d" , &s[i].a , &s[i].b);
		 } 
		 for(int i = m - 1 ; i >= 0 ; i--)
		 {
		 	if(	merge(s[i].a , s[i].b))
		 	{
		 		ans[++t] = --total;
			 }
			 else
			 {
			 	ans[++t] = total;
			 }
			 merge(s[i].a , s[i].b);
		 }
		 
		 for(int i = t-1 ; i >= 0 ; i--)
		 {
		 	printf("%d\n" ,ans[i]);
		 }
	}
	
	return 0;
}

 

全部评论

相关推荐

千疮百孔的象牙塔:我也在捣鼓im,你这个im好奇怪的样子,单看简历get不到点,im的消息及时性,消息可靠性,然后系统的可扩展性这几个关键问题都是怎么解决的从简历描述get不到,具体说消息怎么传,消息怎么推送,消息怎么存,消息安全怎么做的这些点感觉对应不起来
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务