【完全背包】poj2063

Investment

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
Value Annual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050
  
由于股票价格是1000的整数,所以可以除以容量和价格都1000以后再进行状态转移(虽然总钱数不一定是1000的整数倍,但这些零头不会参加购买股票)
注意 每年的总钱数会发生变化。
   
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
long t, v, n, m, y;
long f[60000];
long c[100], w[100];
long max(long a,long b)
{
    return a > b ? a : b;
}
void CompeletPack(long c, long w)
{
    for (long i = c; i <= v; i++ )
    {
        f[i] = max (f[i], f[i - c] + w);
    }
}
int main()
{
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d%d", &m, &y, &n);
        for (long i = 1; i <= n; i++)
        {
            scanf("%d%d", &c[i], &w[i]);
            c[i] /= 1000;
        }
        v = m / 1000;
        for (long j = 1; j <= y; j++)
        {
            memset(f, 0, sizeof(f));
            for (long i = 1; i <= n; i++)
            {
                CompeletPack(c[i], w[i]);
            }
            m += f[v];
            v = m / 1000;
        }
        printf("%d\n", m);
    }

    return 0;
}


全部评论

相关推荐

03-30 21:02
已编辑
武汉大学 Java
ALEX_BLX:虽然说聊天记录不可信,不过这个趋势确实如此但我觉得也要想到一点就是卷后端的人里真正有“料”的人又有多少,我说的这个料都不是说一定要到大佬那种级别,而是就一个正常的水平。即使是现在也有很多人是跟风转码的,2-3个月速成后端技术栈的人数不胜数,但今时不同往日没可能靠速成进大厂了。这种情况就跟考研一样,你能上考场就已经打败一半的人了
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务