【二分图最大匹配】poj2239

Selecting Courses

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects. 

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4
  
选课,给出每个课程的几个上课时间,问一个人最多能选多少科
又是一道模板题……将科目与时间连边,一次匈牙利算法,最大匹配即为所求
   
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const long N = 310, M = 120, m = 12 * 7;
long a[N][M];
bool b[M];
long link[M];
long n;
void init()
{
    memset(link, 0, sizeof(link));
    memset(a, 0, sizeof(a));
    for (long i = 1; i <= n; i++)
    {
        long t;
        scanf("%d", &t);
        for (long j = 1; j <= t; j++)
        {
            long q, x, tmp;
            scanf("%d%d", &q, &x);
            tmp = (q - 1) * 12 + x;
            a[i][tmp] = 1;
        }
    }
}
bool find (long x)
{
    for (long i = 1; i <= m; i++)
    {
        if ((!b[i]) && a[x][i])
        {
            b[i] = true;
            if ((link[i] == 0) || (find(link[i])))
            {
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    freopen("poj2239.in", "r", stdin);
    while (scanf("%d", &n) != EOF)
    {
        init();
        long cnt =0;
        for (long i = 1; i <= n; i++)
        {
            memset(b, 0, sizeof(b));
            if (find(i))
            {
                cnt++;
            }
        }
        printf("%d\n", cnt);
    }
    return 0;
}


全部评论

相关推荐

点赞 收藏 评论
分享
正在热议
# 牛客帮帮团来啦!有问必答 #
1151571次浏览 17149人参与
# 通信和硬件还有转码的必要吗 #
11202次浏览 101人参与
# 不去互联网可以去金融科技 #
20372次浏览 255人参与
# 和牛牛一起刷题打卡 #
18971次浏览 1635人参与
# 实习与准备秋招该如何平衡 #
203377次浏览 3625人参与
# 大厂无回复,继续等待还是奔赴小厂 #
4972次浏览 30人参与
# OPPO开奖 #
19200次浏览 267人参与
# 通信硬件薪资爆料 #
265901次浏览 2484人参与
# 国企是理工四大天坑的最好选择吗 #
2220次浏览 34人参与
# 互联网公司评价 #
97683次浏览 1280人参与
# 简历无回复,你会继续海投还是优化再投? #
25036次浏览 354人参与
# 0offer是寒冬太冷还是我太菜 #
454864次浏览 5124人参与
# 国企和大厂硬件兄弟怎么选? #
53903次浏览 1012人参与
# 参加过提前批的机械人,你们还参加秋招么 #
14644次浏览 349人参与
# 硬件人的简历怎么写 #
82286次浏览 852人参与
# 面试被问第一学历差时该怎么回答 #
19397次浏览 213人参与
# 你见过最离谱的招聘要求是什么? #
28087次浏览 248人参与
# 学历对求职的影响 #
161236次浏览 1804人参与
# 你收到了团子的OC了吗 #
538713次浏览 6386人参与
# 你已经投递多少份简历了 #
344216次浏览 4963人参与
# 实习生应该准时下班吗 #
96976次浏览 722人参与
# 听劝,我这个简历该怎么改? #
63524次浏览 622人参与
牛客网
牛客企业服务