PAT(树)——1094 The Largest Generation (25 分)

1094 The Largest Generation (25 分)
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

题目大意:

给出家庭结构树,求哪一代人数最多。

题目解析:

结构体保存孩子数组和级别,dfs遍历。

具体代码:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
bool isC[110]={false};
struct node{
	int level;
	vector<int> child;
}A[110];
void dfs(int root){
	for(int i=0;i<A[root].child.size();i++){
		int child=A[root].child[i];
		A[child].level=A[root].level+1;
		dfs(child);
	}
}
int main()
{
    freopen("data.in","r",stdin);
    int n,m,root;
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
    	int parent,k;
    	scanf("%d",&parent);
    	scanf("%d",&k);
    	for(int j=0;j<k;j++){
    		int child;
    		scanf("%d",&child);
    		isC[child]=true;
    		A[parent].child.push_back(child);
		}
	}
	root=1;
	A[root].level=1;
	dfs(root);
	int maxlevel=1,maxnum=1;
	for(int i=1;i<n;i++){
		int num=0;
		for(int j=1;j<=n;j++){
			if(A[j].level==i){
				num++;
				if(num>maxnum){
					maxnum=num;
					maxlevel=i;
				}
			}
		}
	}
	printf("%d %d",maxnum,maxlevel);
    return 0;
}
全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务