HDU 2028 - Lowest Common Multiple Plus (最小公倍数)
Problem Description
求n个数的最小公倍数。
Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
Sample Input
2 4 6
3 2 5 7
Sample Output
12
70
题意:
求最小公倍数。
最大公约数: 辗转相除法。
最小公倍数:最小公倍数 = m*n / 最大公约数 .
a = (a / gcd(a,b) ) * b.
代码:
#include<stdio.h>
int gcd(int a,int b)
{
if(a % b == 0)
return b;
else
{
return gcd(b , a % b);
}
}
int main()
{
int n,i,a,b;
while(scanf("%d",&n)!=EOF)
{
scanf("%d",&a);
n-=1;
while(n--)
{
scanf("%d",&b);
a=(a/gcd(a,b))*b;
}
printf("%d\n",a);
}
return 0;
}