PAT(排序)——1083 List Grades (25 分)

1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题目大意:

给出姓名学号和成绩,按照成绩从高到低排序输出指定区间。

题目解析:

结构体+排序。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct node{
	char name[11];
	char id[11];
	int grade;
};
vector<node> A;
bool cmp(node a,node b){
	return a.grade>b.grade;
}

int main()
{
    int n,low,high;
    scanf("%d",&n);
    while(n--){
    	node t;
    	getchar();
		scanf("%s %s %d",&t.name,&t.id,&t.grade);
		A.push_back(t);
	}
	scanf("%d%d",&low,&high);
	sort(A.begin(),A.end(),cmp);
	int flag=1;
	for(vector<node>::iterator it=A.begin();it!=A.end();it++){
		if(it->grade>=low&&it->grade<=high){
			printf("%s %s\n",it->name,it->id);
			flag=0;
		}
	}
	if(flag) printf("NONE\n");
    return 0;
}
全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务