HDOJ 2105 The Center of Gravity(超级水题)

The Center of Gravity

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5708    Accepted Submission(s): 3285


Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
 

Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
 

Output
For each case, print the coordinate, accurate up to 1 decimal places.
 

Sample Input
2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0
 

Sample Output
3.0 2.7 2.0 2.3
 

Source


思路:%.f有自带四舍五入功能

代码:
#include<cstdio>
#include<iostream>
using namespace std;

int main() 
{
	int num;
	while(cin>>num&&num)
	{
		for(int i=0;i<num;i++)
		{
			double x1,x2,x3,y1,y2,y3;
			cin>>x1>>y1>>x2>>y2>>x3>>y3;
			double x=(x1+x2+x3)/3.0;
			double y=(y1+y2+y3)/3.0;
			printf("%.1f %.1f\n",x,y);//printf格式自带四舍五入 
		}
	}
	return 0;
}

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务