HDU 2844 Coins(多重背包)

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10 
1 2 4 2 1 1 
2 5 
1 4 2 1 
0 0

Sample Output


4

题目大意:

输入n和m分别表示拥有的钱币种数和所能买的最大价值,数组a存钱币的价值,数组c存每种钱币个数,求用这些钱币所能买到的最大价值。输入0 0表示结束。

C++

#include <iostream>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;
int f[111111],a[111],c[111];
int n,m;
void OneZeroPack(int m,int v,int w)//01
{
    for(int i=m;i>=v;i--)
        f[i]=max(f[i],f[i-v]+w);
}
void CompletePack(int m,int v,int w)//完全
{
    for(int i=v;i<=m;i++)
        f[i]=max(f[i],f[i-v]+w);
}
void MultiplePack(int m,int v,int w,int num)  //多重
{
    if(v*num>=m)
    {
        CompletePack(m,v,w);
        return ;
    }
    int k=1;
    for(k=1;k<=num;k<<=1)
    {
        OneZeroPack(m,k*v,k*w);
        num=num-k;
    }
    if(num)
        OneZeroPack(m,num*v,num*w);
}
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)  break;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
            cin>>c[i];
        memset(f,-INF,sizeof(f));
        f[0]=0;
        for(int i=0;i<n;i++)
        {
            MultiplePack(m,a[i],a[i],c[i]);
        }
        int sum=0;
        for(int i=1;i<=m;i++)
                if(f[i]>0)
                    sum++;
        cout<<sum<<endl;
    }
    return 0;
}





全部评论

相关推荐

#简历#先说一说我自己的想法,很多人都很排斥苍穹外卖,认为没什么技术点和含金量,但实际上我觉得恰恰相反,苍穹外卖虽然代码本身并不是你自身能力的证明,但是是作为一个新人学习时很好的跳板和原始框架,在这个框架上进行的改进可以很好的辐射到你自己的个人成果上,并作为你和面试官聊天的筹码大多数人的苍穹外卖只写增删改查,千篇一律,吸引不了面试官,所以这才让大家误以为只要是苍穹外卖就不要写进简历里这种误区,但实际上如果你在原有的层面上进行改进,并作为你的项目亮点和面试官介绍,告诉他你的苍穹外卖和别人的有什么不同,增加了哪些技术难点,这才显得你是完全自己理解了这个项目,并且有自己动手实践项目的能力,而不是就看了个课程就以为自己会了,就当成自己的了,如此一来,这反而成为你的加分项苍穹外卖为什么看的人最多,说明它好啊,如果它不好,为什么看的人还这么多,想清楚这个逻辑,我觉得要做的最重要的事,就是如何在原有框架上进行改进提效,比起听其他人的话重新搞一个项目性价比高得多,而且我亲测项目并没有成为我找到工作的阻碍,我投的大厂一大半都给我面试了,而且很多不止一个部门,退一万步说,当你手头没有其他项目的时候,有苍穹外卖总比什么都没有的好很多,不需要因为苍穹外卖有任何心理负担关于简历的任何部分都欢迎大家提意见,十分感谢大家,祝大家找实习+秋招顺利上岸,offer拿到手软#简历中的项目经历要怎么写##我的上岸简历长这样##最后再改一次简历##简历##简历被挂麻了,求建议#
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务