UVALive - 3635 Pie

My birthday is coming up and traditionally I’m
serving pie. Not just one pie, no, I have a number
N of them, of various tastes and of various sizes. F
of my friends are coming to my party and each of
them gets a piece of pie. This should be one piece
of one pie, not several small pieces since that looks
messy. This piece can be one whole pie though.
My friends are very annoying and if one of them
gets a bigger piece than the others, they start complaining.
Therefore all of them should get equally
sized (but not necessarily equally shaped) pieces,
even if this leads to some pie getting spoiled (which
is better than spoiling the party). Of course, I want
a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and
they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number of pies and the number
of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can
all get a pie piece of size V . The answer should be given as a oating point number with an absolute
error of at most 10−3
.
Sample Input


3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output

25.1327
3.1416
50.2655

有m+1个人分n块蛋糕,每个人必须得到一整块蛋糕,而不是拼凑而来,而且每个人蛋糕的大小是一样的,求每个人可以分到的蛋糕的最大值。

 //Asimple
#include <bits/stdc++.h>
#define swap(a,b,t) t = a, a = b, b = t
#define CLS(a, v) memset(a, v, sizeof(a))
#define debug(a)  cout << #a << " = "  << a <<endl
using namespace std;
typedef long long ll;
const int maxn = 10000+5;
const double PI=acos(-1.0);
const int INF = ( 1 << 16 ) ;
ll n, m, res, ans, len, T, k, num, sum, l;
double a[maxn];

bool ok(double area){
	sum = 0;
	for(int i=0; i<n; i++) sum += floor(a[i]/area);
	return sum >= m+1;
}

void input() {
	ios_base::sync_with_stdio(false);
	cin >> T;
	while( T-- ) {
		cin >> n >> m;
		double Max = -1;
		for(int i=0; i<n; i++) {
			ll r;
			cin >> r;
			a[i] = PI*r*r;
			Max = max(Max, a[i]);
		}
		double L = 0, R = Max;
		while( R-L>10e-5) {
			double mid = (L+R)/2;
			if( ok(mid) ) L = mid;
			else R = mid;
		}
		printf("%.4lf\n", L);
	}
}

int main(){
	input();
	return 0;
}

  

全部评论

相关推荐

05-07 17:58
门头沟学院 Java
wuwuwuoow:1.简历字体有些怪怪的,用啥写的? 2.Redis 一主二从为什么能解决双写一致性? 3.乐观锁指的是 SQL 层面的库存判断?比如 stock > 0。个人认为这种不算乐观锁,更像是乐观锁的思想,写 SQL 避免不了悲观锁的 4.奖项证书如果不是 ACM,说实话没什么必要写 5.逻辑过期时间为什么能解决缓存击穿问题?逻辑过期指的是什么 其实也没什么多大要改的。海投吧
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务