并查集—— How Many Tables 详细题解

How Many Tables
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

  1. 做题步骤:
    1.1 理解题意:
    1.2 分析题目条件和细节
    1.3 考虑和确定使用的算法和解题思路
    1.4 计算时间复杂度和算法或者代码优化
    1.5 检查代码,确定代码。

    1. 题意:
      晚饭时间,很多人要一起吃晚饭,所有人都不愿意和陌生人坐一起,对于不是陌生人,也就是朋友,我们这样定义,如果A认识B,而B认识C,则意味着A,B,C彼此认识,因此它们可以呆在一张桌子上。
      对于很多个人,我们需要找出一个方案使得需要的桌子最小。
    2. 分析
      对于可以做一桌的朋友,我们将他们放在一个桌子,不管人数有多少。这样我们最后计算的结果就是集合的个数。
    3. 确定算法或者解题思路
      对于这个题目,我们很快就可以想起我们之前学过的算法,并查集,将很多有连续的朋友组成一个集合。
    4. 计算时间复杂度和考虑算法优化的可能
      首先我们认识到并查集的时间复杂度:查询的时间复杂度为 O(1) ,合并的时间复杂度为 O(n)。
      题目的n是1000,t是25,最多是O(25*1000);
  2. 小结提高:
    2.1. 算法小结和新的认识
    2.2. 思路和代码的优化
    2.3. 一些需要注意的问题、

    1. 并查集小结
      1. 初始化
        把每个点所在集合初始化为其自身。
        通常来说,这个步骤在每次使用该数据结构时只需要执行一次时间复杂度O(1),无论何种实现方式,时间复杂度均为O(N)。

      2. 查找
        查找元素所在的集合,即根节点。

      3. 合并
        将两个元素所在的集合合并为一个集合。
        通常来说,合并之前,应先判断两个元素是否属于同一集合,这可用上面的“查找”操作实现。

    2. 思路代码:
    3. 注意问题:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int a[1005],b[1005];
void xset(int n)  //初始化,将自己定义为根;
{
   
    int i;
    for(i=1;i<=n;i++)
        a[i]=i;
}
int findshu(int x)  //这个函数用来找到自己所属的集合,返回的是自己所属集合的名称
{
   
    while(x!=a[x])
        x=a[x];
    return x;
}
void judge(int x,int y)  //此函数用来合并两个朋友的所属集合,使它们在一个集合里面
{
   
    int i=findshu(x);
    int j=findshu(y);
    if(i!=j)
        a[i]=j;
}
int main()
{
   
    int t,n,m,i,x,y;
    scanf("%d",&t);
    while(t--)
    {
   
        int j=0;
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        xset(n);
        for(i=1;i<=m;i++)
        {
   
            scanf("%d%d",&x,&y);
            judge(x,y);
        }
        for(i=1;i<=n;i++)
        {
   
            if(b[findshu(a[i])]++==0)  //a[i]是第i个人的集合名称,findshu( )是用来找到a[i]的所属集合
                j++;    //在同一个集合中的人共用一张桌子,一个集合只被计数一次
        }
        cout<<j<<endl;
    }
    return 0;
}
全部评论

相关推荐

比亚迪深圳规划院 产品经理 0.9×1.36×12
点赞 评论 收藏
转发
点赞 收藏 评论
分享
牛客网
牛客企业服务