PAT甲级1099

1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N1, and 0 is always the root. If one child is missing, then − will represent the NULL child pointer. Finally Ndistinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
			

Sample Output:

58 25 82 11 38 67 45 73 42
			
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 105;
struct nod
{
	int data;
	int lchild;
	int rchild;
}node[maxn];
int n,num=0,a[maxn];
void inorder(int root)//利用中序遍历输入各节点的data,首先要递增排序输入的数字序列,原理:二叉查找树
//中序遍历既是递增序列
{
	if (root==-1)return;
	inorder(node[root].lchild);//一直递归到最左边的节点,
	node[root].data = a[num++];//节点赋值
	inorder(node[root].rchild);//一直递归到最右边的节点,
}
int ant = 0;
void BFS(int root)
{
	queue<int>q;
	q.push(root);
	while (!q.empty())
	{
		int temp = q.front();
		q.pop();
		ant++;
		cout<<node[temp].data;
		if (ant != n)
			cout << " ";
		else
			cout << endl;
		if (node[temp].lchild != -1)
			q.push(node[temp].lchild);
		if (node[temp].rchild != -1)
			q.push(node[temp].rchild);
	}
}
int main()
{
	FILE* stream1;
	freopen_s(&stream1, "input.txt", "r", stdin);
	cin >> n;
	for (int i = 0; i<n; i++)
		cin >> node[i].lchild >> node[i].rchild;
	for (int i = 0; i<n; i++)
	{
		cin >> a[i];
	}
	sort(a, a + n);
	inorder(0);
	BFS(0);
	return 0;
}


代码学习笔记 文章被收录于专栏

学习笔记,pat,牛客

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务