PAT甲级1064

1064 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0
			

Sample Output:

6 3 8 1 5 7 9 0 2 4
			
#include<iostream>//静态实现完全二叉树,父节点root,左孩子2*root,右孩子2*root+1,数组下标储存,此时输入数据,然后从小到大排列,然后中序遍历,递归输入 因为最左边的是最小的
//然后直接顺序输出B数组,静态实现完全二叉树其实就是层序遍历实现的
#include<algorithm>
#include<vector>
using namespace std;
const int maxn = 1005;
int n, a[maxn], b[maxn], index = 0;
void inorder(int root)
{
	if (root> n)return;
	inorder(root * 2);
	b[root]=a[index++];
	inorder(root * 2+1);
}
int main()
{
	while (cin >> n)
	{
		for (int i = 0; i < n; i++)
			cin >> a[i];
		sort(a, a+n);
		inorder(1);
		for (int i = 1; i <=n; i++)
		{
			cout << b[i];
			if (i != n)
				cout << " ";
			else
				cout << endl;
		}
	}
	return 0;
}


代码学习笔记 文章被收录于专栏

学习笔记,pat,牛客

全部评论

相关推荐

比亚迪深圳规划院 产品经理 0.9×1.36×12
点赞 评论 收藏
转发
点赞 收藏 评论
分享
牛客网
牛客企业服务