PAT甲级1004

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, and M (<), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K] 
			

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02
			

Sample Output:

0 1
			
DFS
#include<iostream>
//#include<queue>
#include<vector>
using namespace std;
#define maxn 110
vector<int>node[maxn];
int deep[maxn] = { 0 }, n, m,maxh=0;
void DFS(int index, int h)
{
	maxh = max(maxh, h);
	if (node[index].size() == 0)
	{
		deep[h]++;
		return;
	}
	for (int i = 0; i < node[index].size(); i++)
		DFS(node[index][i], h + 1);
}
int main()
{
	cin >> n >> m;
	int id,k,cid;
	for (int i = 1; i <= m; i++)
	{
		cin >> id >> k;
		for (int j = 0; j < k; j++)
		{
			cin >> cid;
			node[id].push_back(cid);
		}
	}
  DFS(1,1);
	printf("%d", deep[1]);
	for (int i = 2; i <= maxh; i++)
		printf(" %d", deep[i]);
	return 0;	
}

BFS
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
#define maxn 110
vector<int>node[maxn];
int deep[maxn] = { 0 }, n, m,maxh=0;
int high[maxn] = { 0 };
void BFS()
{
	queue<int>q;
	q.push(1);
	while (!q.empty())
	{
		int top = q.front();
		q.pop();
		maxh = (maxh, high[top]);
		if (node[top].size() != 0)
		{
			for (int i = 0; i < node[top].size(); i++)
			{
				high[node[top][i]] = high[top] + 1;
				q.push(node[top][i]);
			}
		}
		else
			deep[high[top]]++;
	}
}
int main()
{
	cin >> n >> m;
	int id,k,cid;
	for (int i = 1; i <= m; i++)
	{
		cin >> id >> k;
		for (int j = 0; j < k; j++)
		{
			cin >> cid;
			node[id].push_back(cid);
		}
	}
	high[1] = 1;
	BFS();
	printf("%d", deep[1]);
	for (int i = 2; i <= maxh; i++)
		printf(" %d", deep[i]);
	return 0;	
}

注意当只有一个节点时既是根节点又是叶子节点
代码学习笔记 文章被收录于专栏

学习笔记,pat,牛客

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务