PAT甲级1053(算法笔记9.3)

1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, M (<), the number of non-leaf nodes, and 0, the given weight number. The next line contains N positive numbers where Wi (<) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K] 
	

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence { is said to be greater than sequence { if there exists 1 such that Ai=Bi for ,, and Ak+1>Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
	

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
	

静态建立树,并求根节点到叶节点的权重之和=s的所有情况,非递减输出所有权重情况;

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
#define maxn 105
struct Node
{
	int data;
	vector<int>child;
}node[maxn];
bool cmp(int a, int b)//对node里child数组里的元素进行排序,排序规则是node[a].data > node[b].data,这样可以做到非递增输出
{
	return node[a].data > node[b].data;
}
int n, m, s;
int path[maxn];//自己写的用path直接保存了路径上的权重值,也可以直接保存路径的编号,大同小异
void BFS(int idex, int num, int sum)
{
	if (sum > s)return;
	if (sum == s )
	{
		if(node[idex].child.size() != 0)
			return;
		for (int i = 0; i < num; i++)
		{
			cout << path[i];
			if (i != num-1)
				cout << " ";
			else
				cout << endl;
		}
		return;
	}
	int len = node[idex].child.size();
	for (int i = 0; i < len; i++)
	{
		int child = node[idex].child[i];
		path[num] = node[child].data;
		BFS(child, num+1,sum + node[child].data);
	}
}
int main()
{
	FILE* T;
	freopen_s(&T, "input.txt", "r", stdin);
	cin >> n >> m >> s;
	int pos,cnt, child;
	for (int i = 0; i < n; i++)
		cin >> node[i].data;
	for (int i = 0; i < m; i++)
	{
		cin >> pos >> cnt;
		for (int j = 0; j < cnt; j++)
		{
			cin >> child;
			node[pos].child.push_back(child);
		}
		sort(node[pos].child.begin(), node[pos].child.end(),cmp);
	}
	path[0] = node[0].data;
	BFS(0, 1, node[0].data);
	return 0;
}


代码学习笔记 文章被收录于专栏

学习笔记,pat,牛客

全部评论

相关推荐

1 收藏 评论
分享
牛客网
牛客企业服务