05-树8 File Transfer (25 分)【每日一题】

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤10​4), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:
I c1 c2
where I stands for inputting a connection between c1 and c2; or
C c1 c2
where C stands for checking if it is possible to transfer files between c1 and c2; or S ,where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

Code

#include <stdio.h>
#include <stdlib.h>
#define MaxSize 10000

typedef int ElementType;
typedef struct{
    int Parent;
    ElementType Data;
}SetType;

SetType Set[MaxSize];

void Connect(ElementType C1,ElementType C2);
int Find(ElementType X);
int NumOfComponents(int N);
int Check(ElementType C1,ElementType C2);

int main()
{
    int N,k,res;
    ElementType C1,C2;
    char c;
    scanf("%d",&N);

    for(int i=0;i<N;i++)
    {
        Set[i].Data = i+1;
        Set[i].Parent = -1;
    }

    scanf("%c",&c);
    while(c != 'S')
    {
        scanf("%d %d",&C1,&C2);
        if(c == 'C')
        {
            res = Check(C1,C2);
            if(res) printf("yes\n");
            else printf("no\n");
        }else if(c == 'I')
        {
            Connect(C1,C2);
        }
        scanf("%c",&c);
    }

    k = NumOfComponents(N);
    if(k==1)
        printf("The network is connected.\n");
    else
        printf("There are %d components.\n",k);
    return 0;
}

void Connect(ElementType C1,ElementType C2)
{
    int Root1,Root2;
    Root1 = Find(C1);
    Root2 = Find(C2);
//printf("%d root is %d,%d root is %d\n",C1,Root1+1,C2,Root2+1);
//remark:将集合数较少的并到集合数较多的集合中
    if(Root1!=Root2){
        if(Set[Root1].Parent<Set[Root2].Parent){
            Set[Root1].Parent += Set[Root2].Parent;
            Set[Root2].Parent = Root1;
        }else
        {
            Set[Root2].Parent += Set[Root1].Parent;
            Set[Root1].Parent = Root2;
        }
    }

// printf("Set[%d].Parent = %d\n",Root2+1,Root1+1);
}

int Find(ElementType X)
{
    int i = X -1;
    while(Set[i].Parent>=0)
    {
       i =  Set[i].Parent;
    }
    return i;
}

int NumOfComponents(int N)
{
    int k=0;
    for(int i=0;i<N;i++)
    {
        if(Set[i].Parent<0)
        {
            k++;
        }
    }
    return k;
}

int Check(ElementType C1,ElementType C2)
{
    int res,Root1,Root2;
    Root1 = Find(C1);
    Root2 = Find(C2);
// printf("%d root is %d,%d root is %d\n",C1,Root1+1,C2,Root2+1);
    if(Root1 == Root2) res = 1;
    else res = 0;
    return res;
}
全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务