【UVA】10340 All in All

题目链接:All in All 

题目:

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output

Yes

No

Yes

No

分析:

本题是给定字符串s、t,判断是否能从t中删除几个字符,从而得到s。只需要按序判断s中的字符是否等于t当前或后面的字符即可。

注意数组尽量开大,本来设小了,超时。后来试着改大就ac了。 

代码:

#include <stdio.h>
#include <string.h>
int main()
{
	char t[1000010],s[1000010];
	int i,j,ok;
	int lens,lent;
	while (scanf("%s%s",s,t) != EOF)
	{
		ok=0;
		lent=strlen(t);
		lens=strlen(s);
		for (i=0,j=0; i<lent && j<lens; i++)
		{
			if (t[i]==s[j])
			{
				if (j == lens-1)ok=1;
				j++;
			}
		}
		if (ok)printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

 

全部评论

相关推荐

下北泽:都是校友,还是同届,我就说直白点,不委婉了,我相信你应该也不是个玻璃心,首先你觉得一个双非的绩点写简历上有用吗?班长职务有用吗?ccf有用吗?企业会关心你高数满分与否吗?第二,第一个项目实在太烂,一眼就能看出是外卖,还是毫无包装的外卖,使用JWT来鉴权,把热点数据放进Redis这两个点居然还能写进简历里,说难听点这两个东西都是学个几十分钟,调用个API就能完成的事情,在双非一本的条件下,这种项目你觉得能拿出手吗,第二个项目你写的东西和你的求职方向有任何的匹配吗?第三,计设那一块毫无价值,如果想突出自己会前端,直接写入专业技能不行吗,最后,专业技能里像深入理解JVM底层原理这种你觉得这句话你自己真的能匹配吗?都是校友加上同届,我措辞直接,但希望能点出你的问题,想进大厂还得继续沉淀项目和学习
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务