PAT甲级1094

1094 The Largest Generation (25分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K] 
			

where ID is a two-digit number representing a family member, K (>) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
			

Sample Output:

9 4
			
求叶子节点最多的层数,即那层叶结点的个数
#include<iostream>
#include<vector>
using namespace std;
#define maxn 110
vector<int>node[maxn];
int n, m, deep[maxn] = { 0 }, maxh = 0;
void DFS(int index, int h)
{
    deep[h]++;
    if(node[index].size()==0)
     {
       if(maxh<h)
         maxh=h;
       return;
     }
    for (int i = 0; i < node[index].size(); i++)
        DFS(node[index][i], h + 1);
}
int main()
{
    cin >> n >> m;
    int par, k, child;
    for (int i = 0; i < m; i++)
    {
        cin >> par >> k;
        for (int j = 0; j < k; j++)
        {
            cin >> child;
            node[par].push_back(child);
        }
    }
    DFS(1, 1);
    int maxhnum = 0, pos;
    for (int i = 1; i <=maxh; i++)
    {
        if (deep[i] > maxhnum)
        {
            pos = i;
            maxhnum = deep[i];
        }
    }
    cout << deep[pos] << " " << pos << endl;
    return 0;
}


代码学习笔记 文章被收录于专栏

学习笔记,pat,牛客

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务