USACO Section 1.3.6 Prime Cryptarithm

题目

<center style="font&#45;family&#58;&#39;文泉驿微米黑&#39;&#59;font&#45;size&#58;14px&#59;"> Prime Cryptarithm
</center>

The following cryptarithm is a multiplication problem that can be solved by substituting digits from a specified set of N digits into the positions marked with *. If the set of prime digits {2,3,5,7} is selected, the cryptarithm is called a PRIME CRYPTARITHM.

      * * *
   x    * *
    -------
      * * *         <-- partial product 1
    * * *           <-- partial product 2
    -------
    * * * *
Digits can appear only in places marked by `*'. Of course, leading zeroes are not allowed.

Note that the 'partial products' are as taught in USA schools. The first partial product is the product of the final digit of the second number and the top number. The second partial product is the product of the first digit of the second number and the top number.

Write a program that will find all solutions to the cryptarithm above for any subset of digits from the set {1,2,3,4,5,6,7,8,9}.

PROGRAM NAME: crypt1

INPUT FORMAT

Line 1: N, the number of digits that will be used
Line 2: N space separated digits with which to solve the cryptarithm

SAMPLE INPUT (file crypt1.in)

5
2 3 4 6 8

OUTPUT FORMAT

A single line with the total number of unique solutions. Here is the single solution for the sample input:

      2 2 2
    x   2 2
     ------
      4 4 4
    4 4 4
  ---------
    4 8 8 4

SAMPLE OUTPUT (file crypt1.out)

1


思路

简单的枚举,关键在于枚举侧略,我是把第一行看成一个数,第二行看成一个数,枚举这两个数字900*90的复杂度。后面分别判断就行。

代码

/*
ID:zhrln1
PROG:crypt1
LANG:C++
*/
#include <cstdio>
int n,b[11],k,ans;
int hash(int v){
    while (v){
        if (!b[v%10]) return 0;
        v/=10;
    }
    return 1;
}
int main(){
	freopen("crypt1.in","r",stdin);
	freopen("crypt1.out","w",stdout);
	scanf("%d",&n);
	for (int i(1);i<=n;i++){
		scanf("%d",&k);
		b[k]=1;
	}
	for (int i(111);i<1000;i++){
		if (hash(i)){
			for (int j(11);j<100;j++){

				if (i*j<10000 && i*(j/10)<1000 && i*(j%10)<1000 && hash(j) && hash(i*(j%10)) && hash(i*(j/10)) && hash(i*j)) {
                        ans++;
                       // printf("%d * %d = %d0 + %d = %d \n",i,j,i*(j/10),i*(j%10),i*j);
				}
			}
		}
	}
	printf("%d\n",ans);
	return 0;
}



全部评论

相关推荐

用户64975461947315:这不很正常吗,2个月开实习证明,这个薪资也还算合理,深圳Java好多150不包吃不包住呢,而且也提前和你说了没有转正机会,现在贼多牛马公司骗你说毕业转正,你辛辛苦苦干了半年拿到毕业证,后面和你说没hc了😂
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务