hihoCoder #1631 : Cats and Fish

Description:

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input:

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn, ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output:

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input:

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1

Sample Output:

1 0
0 1
0 3

题目连接

暴力模拟。

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 5e3+5;
const double eps = 1e-5;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;

int m, n, x;
int c[maxn];
int a;
int cnt;
int _time[maxn];
int temp;

int main() {
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    while (scanf("%d%d%d", &m, &n, &x) != EOF) {
        mem(_time, 0);
        a = 0; cnt = 0;
        for (int i= 0; i < n; ++i) {
            scanf("%d", &c[i]);
        }
        sort(c, c + n);
        for (int i = 0; i < n; ++i) {
            _time[i] += c[i];
        }
        temp = m < n ? m : n;
        cnt = temp;
        for (int i = 1; i <= x; ++i) {
            for (int j = 0; j < temp; ++j) {
                if (_time[j] == i) {
                    a++;
                    if (cnt >= m) {
                        continue;
                    }
                    _time[j] += c[j];
                    if (i != x) {
                        cnt++;
                    }
                }
            }
        }
        printf("%d %d\n", m - cnt, cnt - a);
    }
   return 0;
}

全部评论

相关推荐

点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务