HDU 2602 简单01背包

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
	
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
	
14 

思路:
第一次认真写01背包题,参考了书上的模板,通过记忆化数组记录数据以避免重复的计算

#include<bits/stdc++.h>
using namespace std;
int n,m;
int a[1010];
int b[1010];
int dp[1010][1010];//记忆化数组 
int num;
int tan(int x,int y)
{
    if(dp[x][y]>=0)    //如果该数组存在有意义数据 直接返回 
    return dp[x][y];
    int num;
    if(x==n)          //没有数据了 
    num=0;
    else if(y<b[x])    //背包空间不足,进入下一组数据 
    {
        num=tan(x+1,y);
    }
    else              //获取 不选取与选取 之间最大的利益 
    {
        num=max(tan(x+1,y),tan(x+1,y-b[x])+a[x]);
    }
    return dp[x][y]=num;  //返回并储存利益 
 }
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
         }
        for(int i=0;i<n;i++)
        {
            cin>>b[i];
        }
        memset(dp,-1,sizeof dp); //初始化数组 
        cout<<tan(0,m)<<endl;
    }
}

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务