暑期集训1:C++&STL 练习题B:HDU-1004

2018学校暑期集训第一天——C++与STL

练习题B ——  HDU - 1004 

B - 双对福音的协议

 

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

我的答案:利用具有映射关系的map处理即可,并需知道如何遍历map

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<map>
#include<set>
using namespace std;

int main(void)
{
	int n;
	while (~scanf("%d", &n) && n != 0) {
		map<string, int> color;
		string co;
		for (int i = 0; i < n; i++) {
			cin >> co;
			color[co]++;
		}
		int j = 0;
		map<string, int>::iterator it;
		for (it = color.begin(); it != color.end(); it++)
			if ((it->second) > j)
				j = it->second;
		for (it = color.begin(); it != color.end(); it++)
			if ((it->second) == j)
				cout << it->first << endl;
	}

	return 0;
}

 

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务