Brackets(括号匹配,区间dp)

https://cn.vjudge.net/problem/POJ-2955

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<map>
#include<vector>
#include<set>
#include<list>
#include<stack>
#include<queue>
using namespace std;
typedef long long ll;
char s[105];
int dp[105][105];
int f(char a,char b){
	if(a=='('&&b==')') return 1;
	if(a=='['&&b==']') return 1;
	return 0;
}
int dfs(int l,int r){
	if(dp[l][r]!=-1) return dp[l][r];
	if(l==r) return dp[l][r]=0;
	if(l+1==r) return dp[l][r]=f(s[l],s[r]);
    int ans=f(s[l],s[r]);
    if(ans) ans+=dfs(l+1,r-1);
    for(int i=l;i<r;i++){//注意是从l开始枚举
    	ans=max(ans,dfs(l,i)+dfs(i+1,r));
	}
	return dp[l][r]=ans;
}
int main(){
    while(~scanf("%s",s+1)){
    	if(s[1]=='e') break;
    	int len=strlen(s+1);
    	memset(dp,-1,sizeof(dp));
    	printf("%d\n",2*dfs(1,len));
	}
	return 0;
}


 

全部评论

相关推荐

点赞 评论 收藏
转发
点赞 收藏 评论
分享
牛客网
牛客企业服务