Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

#include <iostream>
#include <vector>
#include <queue>
#include <cstdio>

using namespace std;

const int INT_MAX2 = ((unsigned int)(-1) >> 1);
const int MAXN = 20005;

// 边
struct _edge {
    int v, cost;
    _edge(int v2, int c){v=v2; cost=c;}
};

// 结点
struct _node {
    int u, cost;
    _node(){}
    _node(int u2, int l){u=u2; cost=l;}

    bool operator<(const _node n) const {
        return cost > n.cost;
    }
};

vector<_edge> g[MAXN+1];
int dist[MAXN+1];
bool visited[MAXN+1];

void dijkstra(int start, int n)
{
    priority_queue<_node> q;

    for(int i=0; i<=n; i++) {
        dist[i] = INT_MAX2;
        visited[i] = false;
    }

    dist[start] = 0;

    q.push(_node(start, 0));

    _node f;
    while(!q.empty()) {
        f = q.top();
        q.pop();

        int u = f.u;
        if(!visited[u]) {
            visited[u] = true;

            int len = g[u].size();
            for(int i=0; i<len; i++) {
                int v2 = g[u][i].v;

                if(visited[v2])
                    continue;

                int tempcost = g[u][i].cost;
                int nextdist = dist[u] + tempcost;

                if(dist[v2] > nextdist) {
                    dist[v2] = nextdist;
                    q.push(_node(v2, dist[v2]));
                }
            }
        }
    }
}

int main()
{
    int n, m, src, dest, cost2, s, t;

    // 输入数据,构建图
    while(scanf("%d%d",&m,&n) != EOF) {
        for(int i=1; i<=m; i++) {
            scanf("%d%d%d", &src, &dest, &cost2);

            g[src].push_back(_edge(dest, cost2));
            g[dest].push_back(_edge(src, cost2));
        }
        //scanf("%d%d", &s, &t);

        // Dijkstra算法
        dijkstra(1, n);

        // 输出结果
        printf("%d\n", (dist[n] == INT_MAX2) ? -1 : dist[n]);//s到t的最短距离

        // 释放存储
        for(int i=0; i<=n; i++)
            g[i].clear();
    }

    return 0;
}

 

全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务