Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output

FAIL
SUCCESS

题意:给你n个电脑的位置,和信号覆盖的的半径d,一开始所有的电脑都坏了,你每单位时间可以进行 O(修复一台电脑),S(检查两台电脑是否联通,间接联通也算),只有修理好的计算机才能连通,如果两台计算机的距离不超过d,则两台电脑之间可以直接连接。

思路:并查集,把每个点d半径圆里的每个点关联;

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,d,f[1010],vis[1010][1010],a,b,flag[1010];//vis记录距离是否可以通信,flag记录是否维修这个电脑 
float x[1010],y[1010];//计算距离时会出现小数,直接用浮点数存储
char c;
int find_root(int x)
{
	if(f[x]!=x)	f[x]=find_root(f[x]);//路径压缩
	return f[x];
}
void union_set(int a,int b)
{
	int fa=find_root(a);
	int fb=find_root(b);
	if(fa!=fb)	f[fa]=fb;
}
int main()
{
	cin>>n>>d;
	for(int i=1;i<=n;i++)	f[i]=i;//每个节点的根节点初始都是自己
	for(int i=1;i<=n;i++)	cin>>x[i]>>y[i];
	for(int i=1;i<=n;i++)
	{
		for(int j=i;j<=n;j++)
			if((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])<=d*d)
				vis[i][j]=vis[j][i]=1;//如果距离在d以内,就记录一下,这两个点之间可以互相通信
	}
	while(~scanf("%c",&c))
	{
		if(c=='O')
		{
			scanf("%d",&a);//修a电脑
			flag[a]=1;
			for(int i=1;i<=n;i++)
				if(i!=a&&vis[a][i]&&flag[i])	union_set(a,i);//如果这个电脑被修过,且两台电脑之间距离小于d
		}
		if(c=='S')
		{
			scanf("%d %d",&a,&b);
			if(find_root(a)==find_root(b))	printf("SUCCESS\n");//如果根节点一样就可以通信
			else	printf("FAIL\n");
		}
	}
	return 0;
}
全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务