03-树2 List Leaves (25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

Code

#include <stdio.h>
#include <stdlib.h>
#define MAXSIZE 10
#define Null -1
struct Node
{
   int left;
   int right;
}Tree[MAXSIZE];

struct QNode
{
   int Data[MAXSIZE];
   int Front;
   int Rear;
};

int ReadTree(struct Node *T);
void LevelorderTraversal(int root);
void AddQueue(struct QNode *q,int X);
int DeleteQueue(struct QNode *q);

int main()
{
   /* 1. 从键盘中读入tree 2.找出根节点 3.从根节点开始层次遍历,输出叶结点,层次遍历使用队列结构处理 */
   int root;
   root = ReadTree(Tree);
   LevelorderTraversal(root);
   return 0;
}
/*读入Tree,并返回根节点*/
int ReadTree(struct Node *T)
{
   int N,root = Null;
   char tmp1,tmp2;
   scanf("%d",&N);
   int check[N];
   if(N){
       for(int i=0;i<N;i++) check[i] = 0;
       for(int i=0;i<N;i++)
       {

           scanf("\n%c %c",&tmp1,&tmp2);
           if(tmp1 == '-')
           {
               Tree[i].left = Null;
           }else
           {
               Tree[i].left = tmp1 - '0';
               check[Tree[i].left] = 1;
           }

           if(tmp2 == '-')
           {
               Tree[i].right = Null;
           }else
           {
               Tree[i].right = tmp2 - '0';
               check[Tree[i].right] = 1;
           }
       }
       for(int i=0;i<N;i++)
       {
           if(check[i] == 0){
               root = i;
               break;
           }
       }
   }
   return root;
}

void LevelorderTraversal(int root)
{
   struct QNode queue;
   int tmp,count=0;
   queue.Front = queue.Rear = 0;
   if(root == Null) return;
   AddQueue(&queue,root);
   while(queue.Front != queue.Rear)
   {
       tmp = DeleteQueue(&queue);
       if(Tree[tmp].left==Null&&Tree[tmp].right==Null)
       {
           if(count==0)
               printf("%d",tmp);
           else
               printf(" %d",tmp);
           count++;
       }

       if(Tree[tmp].left!=Null)
           AddQueue(&queue,Tree[tmp].left);
       if(Tree[tmp].right!=Null)
           AddQueue(&queue,Tree[tmp].right);
   }
}

void AddQueue(struct QNode *q,int X)
{
   q->Data[q->Rear++] = X;
}

int DeleteQueue(struct QNode *q)
{
   return q->Data[q->Front++];
}
全部评论

相关推荐

点赞 收藏 评论
分享
牛客网
牛客企业服务