Is It A Tree? POJ - 1308 (并查集)

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路:如果俩点没有相连 , 看一下他们的父节点是否相同 , 若不相同就将他们相连 , 若相同则表明存在环。

这题输入有些不方便 , 因为0 0的时候是当前输入结束 ,-1 -1是整体结束

我这里用了俩个while循环 , emmm.......可能不太好吧

还有就是要记下他有多少颗树,父节点不同则有多少颗树

代码:

#include <stdio.h>
using namespace std;

const int maxn = 100050;
int father[maxn] , vis[maxn] ,flag;
void init()
{
	for(int i = 1 ; i <= maxn ; i++)
	{
		father[i] = i;
		vis[i] = 0;
	}
}
int getf(int x)
{
	return x == father[x] ? x : father[x] = getf(father[x]);
}
void merge(int x , int y)
{
	vis[x] = 1;
	vis[y] = 1;
	int fx = getf(x);
	int fy = getf(y);
	if(fx != fy)
	{
		father[fx] = fy;
	}
	else
	{
		flag = 1;//说明有环 
	}
}
int main()
{
	int a , b , num = 0 , flag , p;
	while(1)
	{
		flag = 0 , p = 0;
		init();
		scanf("%d %d" , &a , &b);
		if(a == -1 && b == -1)
		{
			break;
		}
		if(a == 0 && b == 0)
		{
			printf("Case %d is a tree.\n" , ++num);
			continue;
		}
		merge(a , b);
		while(1)
		{
			scanf("%d %d" , &a , &b);
			if(a == 0 && b == 0)
			{
				break;
			}
			merge(a , b);
		}
		for(int i = 1 ; i <= maxn ; i++)
		{
			if(vis[i] == 1)
			{
				if(i == father[i])
				{
					p++;
			//		printf(" p = %d\n" , p); 
				}
			}
		}
		if(flag == 0 && p == 1)
		{
			printf("Case %d is a tree.\n" , ++num);
		}
		else
		{
			printf("Case %d is not a tree.\n",++num);
		}
	}
	return 0;
}

 

全部评论

相关推荐

king122:实习经历可以重点写这里这里写的清晰一点,分点写。技能特长一般是放在上面的,而且你的实习经历不能只写实现了一些简单的接口,你要去写一些难点和亮点。甚至可以写一些数字指标上去,只要你能配合业务讲出来,根据我说的这些自己简单包装一下,面试应该会更多,至于笔试和八股,那就只能纯靠自己了,对项目包装感兴趣可以找我
点赞 评论 收藏
分享
吐泡泡的咸鱼:我也工作了几年了,也陆陆续续面试过不少人,就简历来说,第一眼学历不太够,你只能靠你的实习或者论文或者项目经历,然后你没有论文,没有含金量高的比赛和奖项,只能看实习和项目,实习来说,你写的实习经历完全不清楚你想找什么工作?行研?数据分析?且写的太少了,再看项目,这些项目先不说上过大学读过研究生的都知道很水,然后对你想找的岗位有什么帮助呢?项目和实习也完全不匹配啊,你好像在努力将你所有的经历都放在简历里想表现你的优秀,但是对于你想找的岗位来说,有什么用呢?最后只能获得岗位不匹配的评价。所以你需要明白你想要找的岗位要求是什么,是做什么的,比如产品经理,然后再看你的经历里有什么匹配的上这个岗位,或者对这个岗位以及这个岗位所在的公司有价值,再写到你的简历上
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务