HDU 6438 Buy and Resell(优先队列)
Description:
The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:
- spend ai dollars to buy a Power Cube
- resell a Power Cube and get ai dollars if he has at least one Power Cube
- do nothing
Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.
Input:
There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.
Output
For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.
Sample Input:
3
4
1 2 10 9
5
9 5 9 10 5
2
2 1
Sample Output:
16 4
5 2
0 0
Hint:
In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. profit = 0
题目链接
这道题目和
CodeForces 865D Buy Low Sell High(优先队列)
几乎一模一样,只是多计算一个操作次数。
在计算当前枚举利润时多加一个数组存储当前队首元素是否被卖出过,若被卖出过则此次操作相当于队首元素在那次操作被卖出在这次操作被买入,相当于没有操作,统计变量相应-1,维护数组。
AC代码:
#include <bits/stdc++.h>
using namespace std;
int main(int argc, char *argv[]) {
int t;
scanf("%d", &t);
for (int Case = 1, n; Case <= t; ++Case) {
scanf("%d", &n);
priority_queue<int, vector<int>, greater<int> > pq;
long long ans = 0, cnt = 0;
map<int, int> vis;
for (int i = 0, x; i < n; ++i) {
scanf("%d", &x);
pq.push(x);
if (pq.top() < x) {
cnt++;
ans += x - pq.top();
if (vis[pq.top()] > 0) {
cnt--;
vis[pq.top()]--;
}
pq.pop();
pq.push(x);
vis[x]++;
}
}
printf("%lld %lld\n", ans, cnt * 2);
}
return 0;
}