【HDU 6027】Easy Summation

                                 Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4002    Accepted Submission(s): 1623


 

Problem Description

You are encountered with a traditional problem concerning the sums of powers.
Given two integers n and k. Let f(i)=ik, please evaluate the sum f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7.

 

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
Each of the following T lines contains two integers n(1≤n≤10000) and k(0≤k≤5).

 

Output

For each test case, print a single line containing an integer modulo 109+7.

 

Sample Input

3

2 5

4 2

4 1

 

Sample Output

33

30

10

 

水题,使劲膜 mod就好

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
#define closeio std::ios::sync_with_stdio(false)
const int mod=1e9+7;

int main()
{
	ll t,n,m,i,j,s,sum;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		sum=0;
		for(i=1;i<=n;i++)
		{
			s=1;
			for(j=1;j<=m;j++)
			{
				s*=i;
				s%=mod;
			}
			sum+=s%mod;
			sum%=mod;
		}
		cout<<sum%mod<<endl;
	}
	return 0;
}

 

 

 

 

全部评论

相关推荐

野猪不是猪🐗:现在的环境就是这样,供远大于求。 以前卡学历,现在最高学历不够卡了,还要卡第一学历。 还是不够筛,于是还要求得有实习、不能有gap等等... 可能这个岗位总共就一个hc,筛到最后还是有十几个人满足这些要求。他们都非常优秀,各方面都很棒。 那没办法了,看那个顺眼选哪个呗。 很残酷,也很现实
点赞 评论 收藏
分享
愤怒的潜伏者在开会:你不攻击他,我可攻击你了
点赞 评论 收藏
分享
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务