【UVA】10340 All in All

题目链接:All in All 

题目:

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output

Yes

No

Yes

No

分析:

本题是给定字符串s、t,判断是否能从t中删除几个字符,从而得到s。只需要按序判断s中的字符是否等于t当前或后面的字符即可。

注意数组尽量开大,本来设小了,超时。后来试着改大就ac了。 

代码:

#include <stdio.h>
#include <string.h>
int main()
{
	char t[1000010],s[1000010];
	int i,j,ok;
	int lens,lent;
	while (scanf("%s%s",s,t) != EOF)
	{
		ok=0;
		lent=strlen(t);
		lens=strlen(s);
		for (i=0,j=0; i<lent && j<lens; i++)
		{
			if (t[i]==s[j])
			{
				if (j == lens-1)ok=1;
				j++;
			}
		}
		if (ok)printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

 

全部评论

相关推荐

03-29 12:10
门头沟学院 C++
挣K存W养DOG:散漫消极者淘汰,一眼坑爹。实习几个月转正的时候说你加班太少,能力还行态度不够积极裁了,马上老实。
点赞 评论 收藏
分享
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务